QS Network(ZOJ-1586)(最小生成树)

  |  

Sunny Cup 2003 - Preliminary Round
April 20th, 12:00 - 17:00

Problem E: QS Network

In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS’s have received the message.

A sample is shown below:

tupian

A sample QS network, and QS A want to send a message.

Step 1. QS A sends message to QS B and QS C;

Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

Step 3. the procedure terminates because all the QS received the message.

Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS’s favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.

Input

The 1st line of the input contains an integer t which indicates the number of data sets.

From the second line there are t data sets.

In a single data set,the 1st line contains an interger n which indicates the number of QS.

The 2nd line contains n integers, indicating the price of each QS’s favorate network adapter.

In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.

Constrains:

all the integers in the input are non-negative and not more than 1000.

Output

for each data set,output the minimum cost in a line. NO extra empty lines needed.

Sample Input

1

3

10 20 30

0 100 200

100 0 300

200 300 0

Sample Output

370

题意:
第一行给出T,代表有T组数据。每组数据第一行给出N,代表图有N个结点。接着一行给出N个数,代表每个结点的权值(就是接收器的费用),接着N行每行N个数,矩阵的形式给出各点之间边的权值(也就是连接接收器网线的费用)。最后实际权值就是边的权值加上两个点的权值,输出最小生成树的权值总和即可。

思路:
这道题的话,因为输入的是矩阵,我们用Prim算法更好一些,套下模板即可。

AC代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
#include <stdio.h>
#include <string>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <math.h>
#include <queue>
#include <stack>
#include <map>
#include <set>
typedef long long ll;
const int maxx = 10010;
const int mod = 10007;
const int inf = 0x3f3f3f3f;
const double eps = 1e-8;
using namespace std;
int mapp[maxx][maxx];
int dis[maxx];
int val[maxx];
bool vis[maxx];
int n;
void Prim()
{
int sum = 0;
int now;
for (int i = 1; i <= n; i++)
{
dis[i] = i;
vis[i] = false;
}
for (int i = 1; i <= n; i++)
dis[i] = mapp[1][i];
dis[1] = 0;
vis[1] = true;
for (int i = 1; i < n; i++)
{
now = inf;
int minn = inf;
for (int j = 1; j <= n; j++)
{
if (!vis[j] && dis[j] < minn)
{
now = j;
minn = dis[j];
}
}
if (now == inf)
break;
vis[now] = true;
sum += minn;
for (int j = 1; j <= n; j++)
{
if (!vis[j] && dis[j] > mapp[now][j])
dis[j] = mapp[now][j];
}
}
printf("%d\n", sum);
}
int main()
{
int t;
scanf("%d", &t);
while (t--)
{
scanf("%d", &n);
for (int i = 1; i <= n; i++)
scanf("%d", &val[i]);
for (int i = 1; i <= n; i++)
for (int j = 1; j <= n; j++)
{
scanf("%d", &mapp[i][j]);
mapp[i][j] += val[i] + val[j];
}
Prim();
}
return 0;
}

×

纯属好玩

扫码支持
扫码打赏,你说多少就多少

打开支付宝扫一扫,即可进行扫码打赏哦

文章目录
,
字数统计:87.6k 载入天数...载入时分秒...